古河電工ネットワーク機器の総合ブランド ファイテルネット
古河電工
FITELnetトップ製品ラインナップイベント&セミナーセールス&サポート
Routing to the Future FITELnet
設定例
IPアドレス指定による優先制御の設定
全機種対応
説明
Router AではPC-Aから送信されるパケットを優先して送信し、Router BではPC-A宛のパケットを優先して送信します。
構成
コマンド設定

Router A

ip route 0.0.0.0 0.0.0.0 192.0.2.2
access-list 100 permit ip host 192.168.0.2 any
hostname Router_A
interface lan 1
 ip address 192.168.0.1 255.255.255.0
exit
interface ewan 1
 ip address 192.0.2.1 255.255.255.252
 qos output bandwidth 100M priq
 qos-que priq default-que priority 0 default
 qos-que priq high-que priority 7
 service-policy output high-policy
exit
class-map high-class
 match ip access-group 100
exit
action-map high-action
 set queuing high-que
exit
policy-map high-policy
 class high-class action high-action
exit
end

Router B

ip route 0.0.0.0 0.0.0.0 192.0.2.1
access-list 100 permit ip any host 192.168.0.2
hostname Router_B
interface lan 1
ip address 192.168.10.1 255.255.255.0
exit
interface ewan 1
ip address 192.0.2.2 255.255.255.252
qos output bandwidth 100M priq
qos-que priq default-que priority 0 default
qos-que priq high-que priority 7
service-policy output high-policy
exit
class-map high-class
match ip access-group 100
exit
action-map high-action
set queuing high-que
exit
policy-map high-policy
class high-class action high-action
exit
end
設定手順

Router A

設定内容 画面表示例
特権ユーザモードへの移行
パスワードの入力

設定情報の初期化

設定モードの変更
設定入力
























設定保存



装置再起動
Router>enable
Enter password:
Router#
Router#clear working.cfg
Router#
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 192.0.2.2
Router(config)#access-list 100 permit ip host 192.168.0.2 any
Router(config)#hostname Router_A
Router_A(config)#interface lan 1
Router_A(config-if lan 1)# ip address 192.168.0.1 255.255.255.0
Router_A(config-if lan 1)#exit
Router_A(config)#interface ewan 1
Router_A(config-if ewan 1)# ip address 192.0.2.1 255.255.255.252
Router_A(config-if ewan 1)# qos output bandwidth 100M priq
Router_A(config-if ewan 1)# qos-que priq default-que priority 0 default
Router_A(config-if ewan 1)# qos-que priq high-que priority 7
Router_A(config-if ewan 1)# service-policy output high-policy
Router_A(config-if ewan 1)#exit
Router_A(config)#class-map high-class
Router_A(config-class-map)# match ip access-group 100
Router_A(config-class-map)#exit
Router_A(config)#action-map high-action
Router_A(config-action-map)# set queuing high-que
Router_A(config-action-map)#exit
Router_A(config)#policy-map high-policy
Router_A(config-policy-map)# class high-class action high-action
Router_A(config-policy-map)#exit
Router_A(config)#
Router_A(config)#end
Router_A#
Router_A#save SIDE-A
% saving working-config
% finished saving

Router_A#reset
Going to reset with SIDE-A.frm and SIDE-A
Boot-back not scheduled for next boot.
Next rebooting firmware SIDE-A.frm is fine.
Are you OK to cold start?(y/n)y

Router B

設定内容 画面表示例
特権ユーザモードへの移行
パスワードの入力

設定情報の初期化

設定モードの変更
設定入力
























設定保存



装置再起動
Router>enable
Enter password:
Router#
Router#clear working.cfg
Router#
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 192.0.2.1
Router(config)#access-list 100 permit ip any host 192.168.0.2
Router(config)#hostname Router_B
Router_B(config)#interface lan 1
Router_B(config-if lan 1)# ip address 192.168.10.1 255.255.255.0
Router_B(config-if lan 1)#exit
Router_B(config)#interface ewan 1
Router_B(config-if ewan 1)# ip address 192.0.2.2 255.255.255.252
Router_B(config-if ewan 1)# qos output bandwidth 100M priq
Router_B(config-if ewan 1)# qos-que priq default-que priority 0 default
Router_B(config-if ewan 1)# qos-que priq high-que priority 7
Router_B(config-if ewan 1)# service-policy output high-policy
Router_B(config-if ewan 1)#exit
Router_B(config)#class-map high-class
Router_B(config-class-map)# match ip access-group 100
Router_B(config-class-map)#exit
Router_B(config)#action-map high-action
Router_B(config-action-map)# set queuing high-que
Router_B(config-action-map)#exit
Router_B(config)#policy-map high-policy
Router_B(config-policy-map)# class high-class action high-action
Router_B(config-policy-map)#exit
Router_B(config)#
Router_B(config)#end
Router_B#
Router_B#save SIDE-A
% saving working-config
% finished saving

Router_B#reset
Going to reset with SIDE-A.frm and SIDE-A
Boot-back not scheduled for next boot.
Next rebooting firmware SIDE-A.frm is fine.
Are you OK to cold start?(y/n)y
設定状態の確認 1

アクセスリストを確認します。

Router A Router B
Router_A#show access-lists

Extended IP access list 100
 permit ip host 192.168.0.2 any
Router_B#show access-lists

Extended IP access list 100
 permit ip any host 192.168.0.2
設定状態の確認 2

キューイング状況を確認します。

1.PC-AからPC-Cに通信をおこなった場合、「high-que」にキューイングされ優先度7で転送されます。

Router A Router B
Router_A#show qos queuing

interface : ewan 1
queuing type : PRIQ
queuing-name default-que (default que)
 priority : 0
 queue length/limit : 0/50
 sent/drop packets:
  packets : 0/0
  bytes : 0/0
 period cnt : 0
queuing-name high-que
 priority : 7
 queue length/limit : 0/50
 sent/drop packets:
※packets : 4/0
  bytes : 312/0
 period cnt : 4
Router_B#show qos queuing

interface : ewan 1
queuing type : PRIQ
queuing-name default-que (default que)
 priority : 0
 queue length/limit : 0/50
 sent/drop packets:
  packets : 0/0
  bytes : 0/0
 period cnt : 0
queuing-name high-que
 priority : 7
 queue length/limit : 0/50
 sent/drop packets:
※packets : 4/0
  bytes : 312/0
 period cnt : 4

※:「high-que」のパケット数がカウントされていることを確認してください。

2.PC-BからPC-Cに通信をおこなった場合、「default-que」にキューイングされ、優先度0で転送されます。

Router A Router B
Router_A#show qos queuing

interface : ewan 1
queuing type : PRIQ
queuing-name default-que (default que)
 priority : 0
 queue length/limit : 0/50
 sent/drop packets:
※packets : 4/0
  bytes : 312/0
 period cnt : 4
queuing-name high-que
 priority : 7
 queue length/limit : 0/50
 sent/drop packets:
  packets : 4/0
  bytes : 312/0
 period cnt : 4
Router_B#show qos queuing

interface : ewan 1
queuing type : PRIQ
queuing-name default-que (default que)
 priority : 0
 queue length/limit : 0/50
 sent/drop packets:
※packets : 4/0
  bytes : 312/0
 period cnt : 4
queuing-name high-que
 priority : 7
 queue length/limit : 0/50
 sent/drop packets:
  packets : 4/0
  bytes : 312/0
 period cnt : 4

※「default-que」のパケット数がカウントされていることを確認してください。

ページトップへ

All Rights Reserved, Copyright(C) FURUKAWA ELECTRIC CO., LTD. 2011