古河電工ネットワーク機器の総合ブランド ファイテルネット
古河電工
FITELnetトップ製品ラインナップイベント&セミナーセールス&サポート
Routing to the Future FITELnet
設定例
プロトコル指定による優先制御の設定(PPPoEインタフェース利用時)
全機種対応
説明
RouterのPPPoE1から出力されるパケットについて、以下の優先順位で送信します。
TELNETは優先度7(最優先)
WWWは優先度3
FTPは優先度1
構成
コマンド設定
ip route 0.0.0.0 0.0.0.0 pppoe 1
access-list 1 permit any
access-list 101 permit tcp any any eq telnet
access-list 102 permit tcp any any eq www
access-list 103 permit tcp any any eq ftp
access-list 103 permit tcp any any eq ftp-data
interface lan 1
 ip address 192.168.0.1 255.255.255.0
exit
interface pppoe 1
 qos output bandwidth 100M priq
 qos-que priq default-que priority 0 default
 qos-que priq high-que priority 7
 qos-que priq low-que priority 1
 qos-que priq middle-que priority 3
 service-policy output policy1
 ip nat inside source list 1 interface
 pppoe server internet
 pppoe account ********@***.***.ne.jp ******
 pppoe type host
exit
class-map low-class
 match ip access-group 103
exit
class-map high-class
 match ip access-group 101
exit
class-map middle-class
 match ip access-group 102
exit
action-map low-action
 set queuing low-que
exit
action-map high-action
 set queuing high-que
exit
action-map middle-action
 set queuing middle-que
exit
policy-map policy1
 class high-class action high-action
 class middle-class action middle-action
 class low-class action low-action
exit
end
設定手順
設定内容 画面表示例
特権ユーザモードへの移行
パスワードの入力

設定情報の初期化

設定モードの変更
設定入力














































設定保存



装置再起動
Router>enable
Enter password:
Router#
Router#clear working.cfg
Router#
Router#configure terminal
Router(config)#ip route 0.0.0.0 0.0.0.0 pppoe 1
Router(config)#access-list 1 permit any
Router(config)#access-list 101 permit tcp any any eq telnet
Router(config)#access-list 102 permit tcp any any eq www
Router(config)#access-list 103 permit tcp any any eq ftp
Router(config)#access-list 103 permit tcp any any eq ftp-data
Router(config)#interface lan 1
Router(config-if lan 1)# ip address 192.168.0.1 255.255.255.0
Router(config-if lan 1)#exit
Router(config)#interface pppoe 1
Router(config-if pppoe 1)# qos output bandwidth 100M priq
Router(config-if pppoe 1)# qos-que priq default-que priority 0 default
Router(config-if pppoe 1)# qos-que priq high-que priority 7
Router(config-if pppoe 1)# qos-que priq low-que priority 1
Router(config-if pppoe 1)# qos-que priq middle-que priority 3
Router(config-if pppoe 1)# service-policy output policy1
Router(config-if pppoe 1)# ip nat inside source list 1 interface
Router(config-if pppoe 1)# pppoe server internet
Router(config-if pppoe 1)# pppoe account ********@***.***.ne.jp ******
Router(config-if pppoe 1)# pppoe type host
Router(config-if pppoe 1)#exit
Router(config)#class-map low-class
Router(config-class-map)# match ip access-group 103
Router(config-class-map)#exit
Router(config)#class-map high-class
Router(config-class-map)# match ip access-group 101
Router(config-class-map)#exit
Router(config)#class-map middle-class
Router(config-class-map)# match ip access-group 102
Router(config-class-map)#exit
Router(config)#action-map low-action
Router(config-action-map)# set queuing low-que
Router(config-action-map)#exit
Router(config)#action-map high-action
Router(config-action-map)# set queuing high-que
Router(config-action-map)#exit
Router(config)#action-map middle-action
Router(config-action-map)# set queuing middle-que
Router(config-action-map)#exit
Router(config)#policy-map policy1
Router(config-policy-map)# class high-class action high-action
Router(config-policy-map)# class middle-class action middle-action
Router(config-policy-map)# class low-class action low-action
Router(config-policy-map)#exit
Router(config)#
Router(config)#end
Router#
Router#save SIDE-A
% saving working-config
% finished saving

Router#reset
Going to reset with SIDE-A.frm and SIDE-A
Boot-back not scheduled for next boot.
Next rebooting firmware SIDE-A.frm is fine.
Are you OK to cold start?(y/n)y
設定状態の確認 1

アクセスリストを確認します。

確認内容 画面表示例
アクセスリスト情報を表示




設定が正しいことを確認


設定が正しいことを確認


設定が正しいことを確認
Router#show access-lists

Standard IP access list 1
  permit any

Extended IP access list 101
  permit tcp any any eq telnet

Extended IP access list 102
  permit tcp any any eq www

Extended IP access list 103
  permit tcp any any eq ftp
  permit tcp any any eq ftp-data
設定状態の確認 2

キューイング状況を確認します。

1.PC-AからInternetへのTELNET通信のパケットは「high-que」にキューイングされ、優先度7で送信されます。

確認内容 画面表示例
キューの統計情報を表示




























high-que のパケット数がカウントされていることを確認
Router#show qos queuing

interface : pppoe 1
queuing type : PRIQ
queuing-name default-que (default que)
 priority : 0
 queue length/limit : 0/50
 sent/drop packets:
  packets : 8/0
  bytes : 888/0
 period cnt : 8
queuing-name low-que
 priority : 1
 queue length/limit : 0/50
 sent/drop packets:
  packets : 0/0
  bytes : 0/0
 period cnt : 0
queuing-name middle-que
 priority : 3
 queue length/limit : 0/50
 sent/drop packets:
  packets : 0/0
  bytes : 0/0
 period cnt : 0
queuing-name high-que
 priority : 7
 queue length/limit : 0/50
 sent/drop packets:
  packets : 63/0
  bytes : 4292/0
 period cnt : 63

2.PC-AからInternetへのWWW通信のパケットは「middle-que」にキューイングされ、優先度3で送信されます。

確認内容 画面表示例
キューの統計情報を表示





















middle-que のパケット数がカウントされていることを確認
Router#show qos queuing

interface : pppoe 1
queuing type : PRIQ
queuing-name default-que (default que)
 priority : 0
 queue length/limit : 0/50
 sent/drop packets:
  packets : 8/0
  bytes : 888/0
 period cnt : 8
queuing-name low-que
 priority : 1
 queue length/limit : 0/50
 sent/drop packets:
  packets : 0/0
  bytes : 0/0
 period cnt : 0
queuing-name middle-que
 priority : 3
 queue length/limit : 0/50
 sent/drop packets:
  packets : 57/0
  bytes : 4218/0
 period cnt : 0
queuing-name high-que
 priority : 7
 queue length/limit : 0/50
 sent/drop packets:
  packets : 63/0
  bytes : 4292/0
 period cnt : 63

3.PC-AからInternetへのFTP通信のパケットは「low-que」にキューイングされ、優先度1で送信されます。

確認内容 画面表示例
キューの統計情報を表示














low-que のパケット数がカウントされていることを確認
Router#show qos queuing

interface : pppoe 1
queuing type : PRIQ
queuing-name default-que (default que)
 priority : 0
 queue length/limit : 0/50
 sent/drop packets:
  packets : 8/0
  bytes : 888/0
 period cnt : 8
queuing-name low-que
 priority : 1
 queue length/limit : 0/50
 sent/drop packets:
  packets : 19/0
  bytes : 1361/0
 period cnt : 0
queuing-name middle-que
 priority : 3
 queue length/limit : 0/50
 sent/drop packets:
  packets : 57/0
  bytes : 4218/0
 period cnt : 0
queuing-name high-que
 priority : 7
 queue length/limit : 0/50
 sent/drop packets:
  packets : 63/0
  bytes : 4292/0
 period cnt : 63

ページトップへ

All Rights Reserved, Copyright(C) FURUKAWA ELECTRIC CO., LTD. 2011