古河電工ネットワーク機器の総合ブランド ファイテルネット
古河電工
FITELnetトップ製品ラインナップイベント&セミナーセールス&サポート
Routing to the Future FITELnet
お問い合わせはこちら
 
設定例
朝日ネット社「v6 コネクト IPv4 over IPv6 接続(IPIP)」を利用する
〜LAN側でIPv4とIPv6をデュアルスタックで利用する場合(NAPTで利用する)〜
概要
朝日ネット社の「v6 コネクト IPv4 over IPv6 接続(IPIP)」を利用する場合の設定例です。
「v6 コネクト」については、下記URLをご参照ください。
https://v6connect.net/

【補足・注意点】
固定IPサービスで割り当てられたv4のグローバルアドレスにNAPTして通信を行います。
LAN側ではIPv4とIPv6をデュアルスタックで利用可能です。
v6のprefixはRAで取得する例で、装置はONU(ひかり電話契約がない場合)もしくはホームゲートウェイ(ひかり電話契約がある場合)に接続してください。

構成図

ルータ設定例
(!の行はコメントです。実際に入力する必要はありません。)
この設定を利用したい方は
!
!
! 特権ユーザモードに移行します。
!
Router> enable
Enter password: super ←パスワードを入力します(実際は何も表示されません)。

Router#
!
!
! 基本設定モードに移行します。
!
Router# configure terminal
!
Router(config)# ip route 0.0.0.0 0.0.0.0 tunnel 1 100
!
! DNS リゾルバの設定をします。
!
Router(config)# ip name-server 127.0.0.1
Router(config)# ip resolver-cache-time 60
!
! NAT対象のアクセスリストの設定をします。
!
Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255
!
! アクセスリストによるフィルタリングを設定します。
!
Router(config)#access-list 2100 dynamic permit ip any any
Router(config)#access-list 2300 permit icmp any any
Router(config)#access-list 2400 deny ip any any
Router(config)#access-list 3600 dynamic permit ip any any
Router(config)#access-list 3800 permit udp any any eq 546
Router(config)#access-list 3800 permit icmpv6 any any
Router(config)#access-list 3900 deny ip any any
!
! RAを送信するルータをnexthopに設定をします。
!
Router(config)# ipv6 route ::/0 ewan 1
!
! ProxyDNS機能を利用する設定を行います。
!
Router(config)# proxydns mode both
!
! DHCPサーバ設定を有効にします。
!
Router(config)# service dhcp-server
!
! ダイナミック DNS クライアントの設定をします。
!
Router(config)# http-client 1
Router(config-http-client 1)# request-timeout 10 retry 5
Router(config-http-client 1)#
	method 1 get url http://v6update.asahi-net.or.jp/prefix key xxxxx pass yyyyy
!				key(xxxxxのところ)、
!				pass(yyyyyのところ)に、指定される値を設定して下さい
Router(config-http-client 1)# reference-interface lan 1
Router(config-http-client 1)# source-interface lan 1
Router(config-http-client 1)# logging error
Router(config-http-client 1)# exit
!
! DHCPv4サーバの設定をします。
!
Router(config)# ip dhcp pool lan 1
Router(config-dhcp-pool)# dns-server 192.168.1.1
Router(config-dhcp-pool)# default-router 192.168.1.1
Router(config-dhcp-pool)# exit
!
! ダイナミック DNS サーバに登録に行くタイミングを指定します。
! ewan 1 インタフェースの各種設定をします。
!
Router(config)# interface ewan 1
Router(config-if ewan 1)# ip mtu 1500
Router(config-if ewan 1)# ipv6 enable
Router(config-if ewan 1)# ipv6 nd receive-ra prefix-delegation lan 1
Router(config-if ewan 1)# ipv6 mtu 1500
Router(config-if ewan 1)# ipv6 dhcp client ipv6dns_client
Router(config-if ewan 1)# ipv6 access-group 3600 out
Router(config-if ewan 1)# ipv6 access-group 3800 in
Router(config-if ewan 1)# ipv6 access-group 3900 in
Router(config-if ewan 1)#exit
!
! LAN側インタフェースの各種設定をします。
Router(config)#interface lan 1
Router(config-if lan 1)#ddns-client address ip action http-client 1 delay 30
Router(config-if lan 1)# ip address 192.168.1.1 255.255.255.0
Router(config-if lan 1)# ipv6 enable
Router(config-if lan 1)# ipv6 address autoconfig interface-id X:X:X:X
!				指定されるIPv6アドレスのインターフェースIDを設定して下さい
Router(config-if lan 1)# ipv6 nd send-ra
Router(config-if lan 1)# ipv6 nd other-config-flag
Router(config-if lan 1)# ipv6 dhcp server ipv6dns_server
Router(config-if lan 1)#exit
!
! Tunnel 1 インタフェースの各種設定をします。
!
Router(config)#interface tunnel 1
Router(config-if tunnel 1)# tunnel mode ipip
Router(config-if tunnel 1)# tunnel source ipv6 lan 1
Router(config-if tunnel 1)# tunnel destination X:X:X:X::X
!				指定される事業者側IPv6アドレスを設定して下さい
Router(config-if tunnel 1)# ip mtu 1460
Router(config-if tunnel 1)# ip address A.B.C.D
!				指定される固定IPv4アドレス/32を設定して下さい
Router(config-if tunnel 1)# ip access-group 2100 out
Router(config-if tunnel 1)# ip access-group 2300 in
Router(config-if tunnel 1)# ip access-group 2400 in
Router(config-if tunnel 1)# ip nat inside source list 1 interface
Router(config-if tunnel 1)#exit
!
! DHCPv6クライアントの設定をします。
!
Router(config)#ipv6 dhcp client-profile ipv6dns_client
Router(config-ipv6-dhcp-client-prof)# option-request dns-servers
Router(config-ipv6-dhcp-client-prof)#exit
!
! DHCPv6サーバの設定をします。
!
Router(config)#ipv6 dhcp server-profile ipv6dns_server
Router(config-ipv6-dhcp-server-prof)# dns-server forward dhcp-client ewan 1
Router(config-ipv6-dhcp-server-prof)#exit
!
Router(config)# end
			

ページトップへ

All Rights Reserved, Copyright(C) FURUKAWA ELECTRIC CO., LTD. 2019