設定例
モバイル接続(内蔵5Gモジュール)を使う [ F225で利用可能 ]
概要
データ通信接続用の microSIM が必要です。
sim-profile モードに設定します。
SIM契約 |
account 設定 |
APN設定 |
認証ID |
認証パスワード |
xxxモバイル |
xxx123yyy@xxxxx.xx.jp |
XXX123 |
xxx.yyy.com |
コマンドによる回線切断時の注意
常時接続モードが有効な状態で、mobile disconnect コマンドを実行した場合、常時接続モードは無効となる。
再び常時接続モードを有効とするには以下のいずれかの対応を必要とする。
・mobile connectコマンドを実行する
・SIMプロファイルの設定を変更する(変更後の常時接続モードが有効な場合)
・SIMスロットの切り替えコマンドを実行する (切り替え後の常時接続モードが有効な場合)
・interface Mobileをshutdown ⇒ no shutdownする
インターフェース設定モード
項目
|
FITELnet
|
モバイルインターフェース
|
interface Mobile 1
|
インターフェース名
|
channel-group 2
|
SIM プロファイル名
|
SIM1
|
インターフェース設定
|
interface Port-channel 2
|
SIM プロファイル設定
|
sim-profile SIM1
|
LANインターフェース
|
interface GigaEthernet 1/1 ※
|
インターフェース名
|
channel-group 1
|
VLAN-ID値
|
vlan-id 1
|
ブリッジグループ番号
|
bridge-group 1
|
インターフェース設定
|
interface Port-channel 1
|
※GigaEthernet の設定には必ずvlanidとbridge-groupの設定が必要です。
コマンド設定の例
(!の行はコメントです。実際に入力する必要はありません。)
この設定を利用したい方は
!
!
! 特権ユーザモードに移行します。
!
> enable
password: super ←パスワードを入力します。(実際は表示されない)
!
!
! 基本設定モードに移行します。
!
#configure terminal
!
!
! デフォルトルートをDHCP クライアントが動作するインタフェースに設定します。
!
(config)#ip route 0.0.0.0 0.0.0.0 dhcp port-channel 2
!
!
! DHCP サーバ機能を利用する設定をします。
!
(config)#ip dhcp server-profile DHCP-SERVER-PROF
(config-dhcps DHCP-SERVER-PROF)# address 192.168.0.1 192.168.0.254
(config-dhcps DHCP-SERVER-PROF)# dns 192.168.0.1
(config-dhcps DHCP-SERVER-PROF)# gateway 192.168.0.1
(config-dhcps DHCP-SERVER-PROF)#exit
!
!
! NAT で変換対象とする送信元アドレス
! (ここではLAN 側アドレスを対象とします)を登録します。
!
(config)#ip nat list 1 192.168.0.0 0.0.0.255
!
!
電波状態を10分(600秒)間隔でsyslogに出力する設定をします。
!
(config)#monitor signal-quality logging mobile interval 600
!
!
! GigaEthernet インタフェースに、port-channel をリンク付けします。
!
(config)#interface GigaEthernet 1/1 (*1)
(config-if-ge 1/1)# vlan-id 1
(config-if-ge 1/1)# bridge-group 1
(config-if-ge 1/1)# channel-group 1
(config-if-ge 1/1)#exit
!
!
! Port-channel インタフェース設定モードに移行します。
!
(config)#interface Port-channel 1
!
!
! Port-channel インタフェースにおいて DHCP 機能を有効にします。
!
(config-if-ch 1)# ip dhcp service server
(config-if-ch 1)# ip dhcp server-profile DHCP-SERVER-PROF
!
!
! Port-channel にLAN側IPアドレスを設定します。
!
(config-if-ch 1)# ip address 192.168.0.1 255.255.255.0
!
!
! 基本設定モードに戻ります。
!
(config-if-ch 1)#exit
!
!
! Port-channel インタフェース設定モードに移行します。
!
(config)#interface Port-channel 2
!
! 内蔵5Gモジュールよりアドレスを取得するための、DHCP クライアント機能を有効にします。
!
(config-if-ch 2)# ip dhcp service client
!
! NAT+ の設定をします。
!
(config-if-ch 2)# ip nat inside source list 1 interface
!
! ネットワークブロードキャスト宛の中継パケットをブロードキャストパケットとして中継する設定をします。
! (5Gモジュールの拠点間通信にて必要となるケースがあります)
!
(config-if-ch 2)# ip directed-broadcast enable
!
! 基本設定モードに戻ります。
!
(config-if-ch 2)#exit
!
!
! Mobileインタフェースに、port-channel をリンク付けします。
!
(config)#interface Mobile 1
(config-if-mobile 1)# channel-group 2
!
! Mobileインタフェースで有効にするSIMプロファイルを設定します。
!
(config-if-mobile 1)# sim-profile 1 SIM1 default
!
! 基本設定モードに戻ります。
!
(config-if-mobile 1)#exit
!
!
! SIMプロファイル設定モードへ移行します。
!
(config)#sim-profile SIM1
!
! Mobileの認証に使用するユーザIDとパスワードを設定します(*2)。
!
(config-sim-profile SIM1)# account xxx123yyy@xxxxx.xx.jp XXX123
!
! Mobileで通信するためのPDPタイプをIPv4に指定します。
!
(config-sim-profile SIM1)# pdp ipv4
!
! Mobileで通信するためのAPN名を設定します。
!
(config-sim-profile SIM1)# apn-name xxx.yyy.com
!
! 基本設定モードに戻ります。
!
(config-sim-profile SIM1)#exit
!
!
! 学習フィルタリングの設定をします。
!
(config)#access-list 111 deny ip any any
(config)#access-list 121 spi ip any any
!
(config)#interface Mobile 1
(config-if-mobile 1)# ip access-group 111 in
(config-if-mobile 1)# ip access-group 121 out
(config-if-mobile 1)#exit
!
!
! 内蔵5Gモジュールよりアドレスを取得するための、DHCP パケットを受信許可するフィルタリングの設定をします。
!
(config)#access-list 100 permit udp any eq 67 any eq 68
!
(config)#interface Mobile 1
(config-if-mobile 1)#ip access-group 100 in
(config-if-mobile 1)#exit
!
!
! ProxyDNS 機能を利用する設定をします。
!
(config)#ip name-server 127.0.0.1
(config)#dns-server ip enable
(config)#proxydns domain 1 any * any dhcp port-channel 2
(config)#proxydns address 1 any dhcp port-channel 2
!
!
! 特権ユーザモードに戻ります。
!
(config)#end
!
!
! 設定を保存します。
! 任意の名前で保存して下さい(*3)。
!
#save [ファイル名]
!
!
! 設定を有効にするために refresh をします。
!
#refresh
refresh ok?[y/N]:yes
..................Done
*1:物理ポート番号の設定
*2:本装置ではaccount設定が必須となります。お使いの回線にて、ユーザIDとパスワードが不要な場合でも、何らかの
文字列を設定してご利用ください。
例:account dummy dummy
*3:ファイル名を省略した場合、boot.cfgで保存されます。
装置起動時に適用する設定はboot configurationコマンドで指定することができます(デフォルトはboot.cfg)。
All Rights Reserved, Copyright(C) FURUKAWA ELECTRIC CO., LTD. 2019